Issue
You get error warnings on your Zgemma H.S2 running Wooshbuild that there is no free space on /hdd/movies/ or other such locations on the hdd when there is actually free space. This error is common in the IPTV application.
Cause
This is caused by
- Incorrect mounting of the of the USB, SD card or Hard drive. Either the mount name is wrong or does not exist
- or you have not initialised the media.
- In my case is was because during the installation I intialised a SD Card to be used while it was in rear USB socket and then after the setup was complete I moved it to the SD card reader on the front right which broke the mount name /hdd/
- The media is actually full or faulty.
Solution
All apps seem to be hardcoded to use the /media/hdd/ mount
- Make sure the USB, SD card or Hard drive is in the port it is going to stay in. It can be moved later.
- Intialise the media (optional). This will wipe everything on the drive, so if you have all of your recordings on the media you might not want to do this and only needs to be done in the media is not initialised.
- Power on the Zgemma box
- Once loaded navigate to (Menu --> Info Panel --> Plugins --> Mount Manager)
- You are now in the mount manager and one of the following should be done depending on your situation
- There are no mounts - This means your media is not mounted at all
- Select your device and mount it
- There is one mount present - This assumes you only have 1 external media plugged in.
- edit the mount to make it show /media/hdd/.
- you can change its mount name by using the left and right arrows on the remote
- There are no mounts - This means your media is not mounted at all